Drupal News

  1. Project: 
    Date: 
    2019-July-17
    Vulnerability: 
    Access bypass
    CVE IDs: 
    CVE-2019-6342
    Description: 

    In Drupal 8.7.4, when the experimental Workspaces module is enabled, an access bypass condition is created.

    This can be mitigated by disabling the Workspaces module. It does not affect any release other than Drupal 8.7.4.

    Drupal 8.7.3 and earlier, Drupal 8.6.x and earlier, and Drupal 7.x are not affected.

    Solution: 

    If the site is running Drupal 8.7.4, upgrade to Drupal 8.7.5.

    Note, manual step needed. For sites with the Workspaces module enabled, update.php needs to run to ensure a required cache clear. If there is a reverse proxy cache or content delivery network (e.g. Varnish, CloudFlare) it is also advisable to clear these as well.

    Reported By: 
    Fixed By: 
  2. Project: 
    Date: 
    2019-May-08
    Vulnerability: 
    Third-party libraries
    CVE IDs: 
    CVE-2019-11831
    Description: 

    This security release fixes third-party dependencies included in or required by Drupal core. As described in TYPO3-PSA-2019-007: By-passing protection of Phar Stream Wrapper Interceptor:

    In order to intercept file invocations like file_exists or stat on compromised Phar archives the base name has to be determined and checked before allowing to be handled by PHP Phar stream handling. [...]

    The current implementation is vulnerable to path traversal leading to scenarios where the Phar archive to be assessed is not the actual (compromised) file.

    The known vulnerability in Drupal core requires the "administer themes" permission. However, additional vulnerabilities may exist in contributed or custom modules, so site should still update even if they do not grant this permission.

    Solution: 

    Install the latest version:

    Versions of Drupal 8 prior to 8.6.x are end-of-life and do not receive security coverage.

    Also see the Drupal core project page.

    Reported By: 
    Fixed By: 
  3. Project: 
    Date: 
    2019-April-17
    Vulnerability: 
    Cross Site Scripting
    CVE IDs: 
    CVE-2019-11358
    Description: 

    The jQuery project released version 3.4.0, and as part of that, disclosed a security vulnerability that affects all prior versions. As described in their release notes:

    jQuery 3.4.0 includes a fix for some unintended behavior when using jQuery.extend(true, {},...). If an unsanitized source object contained an enumerable __proto__ property, it could extend the native Object.prototype. This fix is included in jQuery 3.4.0, but patch diffs exist to patch previous jQuery versions.

    It's possible that this vulnerability is exploitable with some Drupal modules. As a precaution, this Drupal security release backports the fix to jQuery.extend(), without making any other changes to the jQuery version that is included in Drupal core (3.2.1 for Drupal 8 and 1.4.4 for Drupal 7) or running on the site via some other module such as jQuery Update.

    2019-04-22, edited to add CVE.

    Solution: 

    Install the latest version:

    Versions of Drupal 8 prior to 8.5.x are end-of-life and do not receive security coverage.

    Also see the Drupal core project page.

    Additional information

    All advisories released today:

    Updating to the latest Drupal core release will apply the fixes for all the above advisories.

    Reported By: 
    Fixed By: 
  4. Project: 
    Date: 
    2019-April-17
    Vulnerability: 
    Multiple Vulnerabilities
    Description: 

    This security release fixes third-party dependencies included in or required by Drupal core.

    • CVE-2019-10909: Escape validation messages in the PHP templating engine. From that advisory:

      Validation messages were not escaped when using the form theme of the PHP templating engine which, when validation messages may contain user input, could result in an XSS.

    • CVE-2019-10910: Check service IDs are valid. From that advisory:

      Service IDs derived from unfiltered user input could result in the execution of any arbitrary code, resulting in possible remote code execution.

    • CVE-2019-10911: Add a separator in the remember me cookie hash. From that advisory:

      This fixes situations where part of an expiry time in a cookie could be considered part of the username, or part of the username could be considered part of the expiry time. An attacker could modify the remember me cookie and authenticate as a different user. This attack is only possible if remember me functionality is enabled and the two users share a password hash or the password hashes (e.g. UserInterface::getPassword()) are null for all users (which is valid if passwords are checked by an external system, e.g. an SSO).

    Solution: 

    Install the latest version:

    Versions of Drupal 8 prior to 8.5.x are end-of-life and do not receive security coverage.

    Also see the Drupal core project page.

    Additional information

    All advisories released today:

    Updating to the latest Drupal core release will apply the fixes for all the above advisories.

    Reported By: 
    Fixed By: 
  5. Project: 
    Date: 
    2019-March-20
    Vulnerability: 
    Cross Site Scripting
    CVE IDs: 
    CVE-2019-6341
    Description: 

    Under certain circumstances the File module/subsystem allows a malicious user to upload a file that can trigger a cross-site scripting (XSS) vulnerability.

    Solution: 

    Versions of Drupal 8 prior to 8.5.x are end-of-life and do not receive security coverage.

    Reported By: 
    Fixed By: 

Customer Login

We recommend the use of Google Authenticator to all of our users for two factor authentication. To find out more about this click here.